CapeSoft.Com
Clarion Accessories
Multi-Proj
Documentation
Multi-Proj Manager
CapeSoft Logo

CapeSoft Multi-Proj Manager
Documentation

Download Latest Version FAQ History
Installed Version Latest Version

Introduction

NOTE: Multi-Proj Manager is no longer required in Clarion 7 and up (and indeed does not support the interaction to the IDE). You will need to build solutions which include your projects to compile the different project sets.

Multi-Proj Manager is a batch tool for generating and compiling Clarion applications. It provides you with the following features:

How to get Technical Support

All comments and suggestions are welcome.
CapeSoft Support
Email
Telephone +27 21 715 4000
Fax +27 21 715 2535
Post PO Box 511, Plumstead, 7801, Cape Town, South Africa

How does it work?

Batch and File Lists

When Multi-Proj loads you see two lists which list the Batches and the Files. A Batch contains a list of Files. Typically a Batch would be the name of your multiple application project. (A multiple application project, would be a project set that has multiple EXEs or multiple DLLs in it). The Files are either PRJ files or APP files.

You can add, rename and delete Batches and Files via 3 ways:
  1. Right clicking in the relevant grid and choose either the New Batch/File, Rename Batch/File or the Delete Batch/File option in the popup menu.
  2. Going to the File Menu and choose either the New, Rename or the Delete Menu.
  3. In the correct list press either the Ins button to insert, the Del button to Delete.
Multi-Proj Manager

Generate, Make, Smart Make and Compile

Once you have inserted a batch and some files in the batch. You can choose one of four types of Generate or Compile

Generate: A Generate will generate the clarion source code files. i.e. It will create the .clw files. It will not build an EXE or DLL. Only applications can be generated (projects are ignored).

Make: A Make will generate applications and compile applications and projects to form EXEs or DLLs.

Smart Make: A Smart Make will generate applications and compile projects. This is very useful when you are building multi-DLL projects using the Multi-Proj template. You applications are generated, and then your project files which have your compile settings for shipping your project are used to build the final EXEs and DLLs.

Compile: A Compile will compile projects. (Applications are ignored). This means that the the .clw files are compiled and linked to form an EXE or DLL.

Please note: The "Make" button does not work on many XP machines. IOW Compiling _apps_ is broken on most XP machines. We recommend _generating_ apps and _compiling_ PRJ's, i.e. "Smart". (Clarion DDE is less stable in XP because it is a 16bit program).

Status after generating and compiling

Multi-Proj gives you feedback as to the success of a generate or compile. Under normal conditions Multi-Proj will delete the target file (i.e. the DLL or EXE) before doing a compile. Multi-Proj will then test to see if the EXE or DLL has been created after the compile. (It is possible to disable this feature in the Tools - Options, but it is not recommended). The following statuses are possible:

Successful Statuses:

generated: Displayed when the file was generated

made: Displayed when the file was made

ran template utility: Displayed after a template utility was executed on the file.

Error Statuses

failed to Make: The compile operation failed to make a new target file.

unsure: This may occur when Multi-Proj is unable to determine what the target file should be, and is therefore unable to monitor the success of the compile operation.

no change: After the make, the date and time of the target file had not changed. This can only occur if you disable 'delete target file before compile' in Tools-Options.

error <error number>: <error message>: Displays error number and message

error: Some error occurred

Other Statuses

skipped: The operation (generate or compile) was skipped for this file.

Selecting which files to process

Multi-Proj allows you perform a generate or compile operation on any of the following 3 sets of files:

All files: To perform an operation on all files simply press either of the 4 operation buttons on the toolbar, or right click in the file list and choose operation in the 'All' menu. This menu is also available under the File menu.

From the selected file and all files below this file: To choose these files simply select the first file you would like to process and then right click and choose an operation inside the 'From here down' menu. This menu is also available under the File Menu.

Just the selected file: To choose these files simply select the file you would like to process and then right click and choose an operation inside the 'Just this file' menu. This menu is also available under the File Menu.

Opening the File in Clarion

Multi-Proj allows you to open a file from your file list straight into Clarion. To do this select a file and right click it and choose the 'Open in Clarion' option. You can also find this menu option in the File menu.

Deleting the Target File

To delete the target file (i.e. the DLL or EXE that would be made from the .app or .prj file), select a file in the file list and right click and choose Delete Target File. You can also find this command in the File menu.

Refreshing the file list

The refresh command will refresh the date and times of the files in your file list. It tells Multi-Proj Manager to recheck the files. You can call this option by pressing the Refresh button on the toolbar or by choosing it in the Tools menu.

Moving items up and down

You can move the order of files up or down in the file list using the Up and Down buttons on the toolbar. This is not recommended if you are using Multi-Proj template in your project files as the dependencies are automatically worked out my Multi-Proj Manager.

Dependencies

Multi-Proj supports file dependencies. This occurs when you create a DLL that is dependent on another DLL. For example you might create a project with a main EXE, and data DLL and an 'other' DLL. Both the main EXE and the 'other' DLL use the data DLL. Therefore the data DLL must be compiled before the other two files. When you use Multi-Proj to manage your multi-app projects, this functionality is automatically detected by Multi-Proj manager.

When you add such a project to Multi-Proj Manager, simply add the main.prj and all the other dependents will be added (in the correct order) to your file list.

Re-evaluating Dependencies

Should you make a change to the dependency flow of your files. Choose the 'Re-evaluate Dependencies' option in the Tools Menu. This will re-order your file list according to your new dependencies.

Multi-Proj Manager Options

Multi-Proj has several options which you can tweak in Tools-Options.

DDE Time Out: This specifies the period of time (in seconds) that Multi-Proj should wait until it assumes there has been an error generating or compiling an application. If you keep getting DDE timeout errors and they are occurring because your application is still being generated or compiled, then increase this time. [Default = 3600 seconds (1 hour)]

Fail wait time: When Multi-Proj detects that one of your applications failed during compile. It displays a notification window, describing the error. It also gives you an option to stop at this point, or to continue. The period of time (again in seconds) in set here. [Default = 30 seconds]

Don't show start up message: This disables the start up message. This option can also be set on the startup message, by clicking the 'Don't show me this message again' option. [Default = off]

Window on Top during Compile: Specifies whether Multi-Proj Manager should stay on top during compile. Warning: If you use this option make sure you resize Multi-Proj Manager so that you can still see the Clarion compile window. [Default = off]

Delete Target before Compile: This option sets whether Multi-Proj Manager will delete the target EXE or DLL before the compile phase. By deleting the target, Multi-Proj Manager is able to give you a more accurate feedback as to the success or failure of the compile. [Default = on]

Clear INI file: This option deletes all your Multi-Proj Manager settings in the Multi-Proj Manager INI file. If you press this button, you will be asked for a confirmation. If you agree to it, the INI file is removed and Multi-Proj Manager is closed down. The new (default) settings will be activated the next time you load Multi-Proj Manager.

Disabling the Toolbar

Multi-Proj Manager gives you the option to remove the toolbar from the Multi-Proj Manager window. Toggle this value in the View menu. Some users have requested this when they are running in 640x480.

Running Template Utilities

Multi-Proj Manager also allows you to execute template utilities on all the files in a batch. Choose Template Utility from the Tools menu. Then enter the Template Utility Name. The correct format is:

<Template Utility Name> (<Template Class>)

List of Errors

Files with spaces: If you use applications or projects with spaces in them, you may find that Clarion returns the focus to Multi-Proj Manager before it has completed doing a compile. This will cause Multi-Proj to say that the compile was unsuccessful. The trick is not to use spaces in your filenames. Spaces in folder names is fine however.

I get all kinds of time-outs and communications problems between the Clarion IDE and the Multi-Proj Manager.
Unfortunately the communication method is DDE, which is less than perfect on windows XP and windows Vista.

Some tips that can help:
a) a reboot from time to time seems to sort out problems on some machines

b) start the Batch compiler EXE from a shortcut (start menu, or desktop) NOT
from inside the Clarion IDE (Accessories menu).

c) Make sure only one version of Clarion is running (i.e. not C55 and C6 at
the same time)

d) start clarion yourself, and close any open windows. (e.g. pick list)

Copyright and License

Multi-Proj and Multi-Proj Manager are copyrighted © 2013 by CapeSoft Software. All rights are reserved. CapeSoft Software trades as CapeSoft.

This product, and all the files contained therein, is copyrighted by CapeSoft Software .

This product is provided as-is. CapeSoft Software, employees of CapeSoft, and Dealers of CapeSoft products, explicitly accept no liability for any loss or damages which occur from using this package. Use of this package constitutes agreement with this license. This package is used entirely at your own risk.

For each copy of Multi-Proj purchased you are entitled to use it with one copy of Topspeed's Clarion for Windows product. You may not in any way distribute the Multi-Proj template or Multi-Proj Manager EXE. You may not derive other templates from the Multi-Proj template.