CapeSoft.Com
Clarion Accessories
Insight Graphing
Documentation
Template Guide
CapeSoft Logo

CapeSoft Insight Graphing
Template Guide

Download Latest Version
Installed Version Latest Version
Documentation Guide Template Guide

Introduction

Welcome to your complete guide to the Insight Graphing Template.

This help page contains detailed help for every significant window and tab in the Insight Graphing Template. To find the window or tab you need help on it is easiest to use the above Table of Contents. The indentation used in the table of contents indicates the path taken to get to a tab on a given window. There will be a section heading matching the name of the tab you are on.

Note that there are two main parts - the Global Template and the Control Template. The Global Template is used to set the global defaults which will be used by all graphs in your application. The Control Template is then used to set the properties for an individual graph. It can also be used to override the global defaults for that graph.

Tip: It is advisable to read the Background section in the Insight User Guide before continuing. If you have doubts as to what a data point, set or point name is, this is where these terms are explained.

Global Template Settings

General Tab

The main purpose of this tab is for you to choose the Template Level of your graphs.
Disable All Insight graphing Features
Click on the option to temporarily remove all Insight Graphs from your application, and to prevent the Insight DLL from linking into your program. This option is typically used when you are unable to compile, or run, your program because of an Insight problem. Clicking on this button will not lose any of your graph settings.

Multi-DLL Tab

This is paer of a Multi-DLL Program
Tick this on if this app is part of a suite of apps making up one program.
Export Insight Classes from this DLL
Thick this on if this specific app will compile, and export, the Insight classes. This is usually only turned on in the "root" or "data" dll, and leaft off in all the other apps in the set.

Basic Tab

This tab allows you to set some basic global defaults relating to line widths, 3D depths and shading.
Line Widths and Depth
This allows you to set the default Line Width for each Graph Type.
Depth for 3D
This allows you to set the default 3D Depth for each graph type.
Disable Auto Shading
Click this on if you want to disable shading throughout the whole application. This includes the shading of bars, and also the shading of the BackWall.

Legend Tab

Use this tab to set the global defaults for the legend of your graphs.
Show Legends
If you click this on then legends will be displayed on all graphs by default. The legend can then be disabled for an individual graph.
Position
Set the default position of the legend for all graphs.
Layout Shape
If this is set to "Stacked", the legends of all the graphs will be stacked vertically. If this is set to "Inline", the legends will be placed side-by-side to fill the line.
Font
Set the Name, Size, Color and Style of the default font to use when creating legends. Click on the Vertical option to have the text printed vertically instead of horizontally.

Grid Tab

This tab allows you to set all the Grid related properties.
Use Grid Style
Insight comes with 20 different built-in Grid styles. If you prefer to make your own style then set this option to 0 (which will make it blank), and the rest of the options on this tab will be enabled.
Back Wall Shaded
If Auto-Shading is on, then by default the back walls of the axis system will be shaded. Switch this option off to suppress this feature on a global level
X-Axis Grid Lines
This allows you to set the Width, Color and Style of the X-Axis Grid Lines. It also allows you to set the default quantity. Note that the x-axis (the line with the x-axis labels) is not counted towards the quantity of grid lines.
Y-Axis Grid Lines
This allows you to set the Width, Color and Style of the Y-Axis Grid Lines. It also allows you to set the default quantity. Note that the y-axis (the line with the y-axis labels) is not counted towards the quantity of grid lines.
Back Wall Color
This lets you set the Line and Fill color for the back wall of the graph. In a 2D graph this is the background color. In a 3D graph it forms the back wall. This block also contains a setting called Line Width. This allows you to set the width of the lines that surround the graph. This setting will apply to the back wall, as well as the side and base walls if they exist.
Side Wall Color (3D Only)
These settings only apply to 3D graphs. They set the left hand side wall Line Color and Fill Color.
Base Wall Color (3D Only)
These settings only apply to 3D graphs. They set the base wall Line Color and Fill Color.

Fonts Tab

This Tab lets you set all the Font related properties. There are 6 different fonts that you can set. These are:
Graph Header
This is the heading that appears at the top of the graph.
X-Axis Name
This is the name of the X-Axis that appears under the X-Axis labels.
X-Axis Labels
These are the labels that appear under the X-Axis. Typically these are values related to the data being graphed.
Y-Axis Name
This is the name of the Y-Axis which appears to the left of the Y-Axis Labels.
Y-Axis Labels
These are the labels which appear just to the left of the Y-Axis. Typically these are the values of the data being plotted.
Data Labels
These are labels that appear on the graph itself, next to the plotted points.

Colors Tab

The colors set on this tab are the colors used by the data on the graph. For example, you would set the colors of the bars in a bar graph, or the colors of the lines in a line graph, here.
Use Data Style
Allows you to select one of the built-in data styles.
Overrides
If you set the Data Style to 0 (which will make it blank), you can create your own color-scheme for each data set using the list box. For each color-scheme you will need to enter the Pen Color, Fill Color and Shadow Color.

Translation Tab

Use this to set the default wording for the Right-Click popup menu items. This is designed primarily for users who are using a language other than English in their programs

Classes Tab

This tab allows you to inspect, or refresh, the Insight classes in the app.

Options for the Insight Graph Control Template

Graph Tab

graph tab screenshot

Properties Tab

properties tab screenshot

This is where you can set the general properties of your graph object.
INSIGHT:FineDiagonal
INSIGHT:CoarseDiagonal
INSIGHT:CoarseVertical
INSIGHT:FineChecked
INSIGHT:CoarseChecked
INSIGHT:CoarseZigZag
INSIGHT:Cross
INSIGHT:Tiles
INSIGHT:CoarseHorizontal
INSIGHT:Kite
INSIGHT:CrossHatch
INSIGHT:Squares
INSIGHT:Ducks
INSIGHT:Smilies
INSIGHT:Stars
INSIGHT:Grey
INSIGHT:Waves
INSIGHT:Zigzag
INSIGHT:VeryThickZigZag
INSIGHT:Chainmail
INSIGHT:SmallVerticalZigZag
INSIGHT:Pebbles
INSIGHT:CoarsePebbles
INSIGHT:LargePebbles
INSIGHT:Mosiac
INSIGHT:LargeDots
INSIGHT:SmallDots
INSIGHT:InversedSmilies
INSIGHT:Circuits
INSIGHT:Empty

Data Tab

data tab screenshot



The Data Tab is where you enter all the files, queues, views and variables you will be plotting data on the graph from. Information regarding sorting, data labels and the style you want your data plotted in is also entered here.

Primary Source Tab

On this tab, you first make a selection from the Data From dropdown (see the point below), and then the remaining options change according to your selection.
primary source tab screenshot

When choosing File, your options are as follows: queue primary sourc tab screenshot

When choosing Queue, your options are as follows:
When choosing Variable, there are no options. Move on to the Sets Tab to specify the variable name. Note that when you choose this option, an extra X-Axis Tab will appear once you get to the Set Window.

view primary source tab screenshot

When choosing Hand-Coded View, your options are as follows:

Related File Tab

related file tab screenshot

This tab is only visible if the Primary Source is a File. It allows you to enter a file related to your primary file from which data will be graphed. The fields of this file can, just as with the primary file, be used on the Set Tab.

Sets Tab

data sets tab screenshot

This is the tab where you specify the actual fields being plotted on the graph. You're allowed to have multiple fields (or expressions) per File (or Queue). Click on the Properties button in the above screenshot to see the tab where this information is entered, or go to the section on the Set Tab below.

Set Window - X-Axis Tab

set window x-axis tab screenshot

This tab only appears in two cases. The first is if you are using a variable - in this case you would have chosen Variable from the Data From dropdown on the Primary Source Tab. The idea is, that since a variable is single-valued, we wont know for which x-axis point the value in that variable should be plotted. Hence, we enter these details here.

The second case where this tab will appear is if you have ticked Sets have own Point Name and Number Fields on the Main X-Axis Tab.

Set Window - Set Tab

set window set tab screenshot

This is where you enter all the details related to the set you want plotted. For example, you specify which field to plot, the graph type of this particular set and how the data should be plotted.

Set Window - Y-Axis Tab (For Intermediate and Advanced Level Graphs where "Use a Separate Y-Axis for each Set " is on)

set window y-axis tab screenshot

To use this window, the Template Level on the global General Tab should be set to Intermediate or Advanced, and "Use a Separate Y-Axis for each Set" on the main Y-Axis Tab should be ticked. Use this tab to specify the details for the y-axis to be used for this set.

Set Window - Colors Tab ( Intermediate and and Advanced Level Graphs)

set window colours tab screenshot

The Colors Tab is used to specify the colors used to draw the data points in this set, including the conditional coloring of data points. Note that this tab is only available when the Template Level on the global General Tab is set to Intermediate or Advanced.

Set Window - Style Tab ( Intermediate and and Advanced Level Graphs)

set window style tab screenshot

This Tab allows you to set the style used to draw your lines, scatter shapes, bars, etc. Note that this tab is only available when the Template Level on the global General Tab is set to Intermediate or Advanced.

Set Window - Advanced Tab (Advanced Level Graphs)

set window advanced tab screenshot

This tab contains a number of advanced options. Note that this tab is only available when the Template Level on the global General Tab is set to Advanced.

Hot Fields Tab (Intermediate and Advanced Level Graphs)

hot fields tab screenshot

This allows you to add additional fields to the view. Note that this tab is only available when the Template Level on the global General Tab is set to Intermediate or Advanced.

X-Axis Tab

x-axis tab screenshot

This tab lets you set all the options relating to the x-axis, including the axis name and labeling information.

Y-Axis Tab

y-axis tab screenshot

This tab lets you set all the options relating to the y-axis, including the axis name and labeling information.

Grid Tab (Intermediate and Advanced Level Graphs)

grid tab screenshot

Use this tab to set the grid properties for your graph. Refer also to the Grid Tab on the Global Extension, where you can set the global defaults for the grid. Note that this tab is only available when the Template Level on the global General Tab is set to Intermediate or Advanced.

Mouse Move Tab (Intermediate and Advanced Level Graphs)

mouse move tab screenshot

This tab is used to specify what should happen when the mouse is moved over the graph area. Typically, you would want the point names and values to be displayed on a tool tip or somewhere on the window. Note that this tab is only available when the Template Level on the global General Tab is set to Intermediate or Advanced. Tip: Insight will not display these values for sets which do not have set names.

Mouse Click Tab (Intermediate and Advanced Level Graphs)

mouse click tab screenshot

The Mouse Click Tab lets you specify what should happen when the mouse is clicked in the graph region. Note that this tab is only available when the Template Level on the global General Tab is set to Intermediate or Advanced.

Tip: See the section on Setting Up a Drill Down/Back Up Sequence.
Tip: See the section on Setting Up a Drill Down/Back Up Sequence.

Legend Tab (Intermediate and Advanced Level Graphs)

legend tab screenshot

This tab is used to override the global settings for the legend specified on the Global Legend Tab. Note that this tab is only available when the Template Level on the global General Tab is set to Intermediate or Advanced.

Fonts Tab

fonts tab screenshot

Use this tab to specify the font details of all text appearing on your graph.

Advanced Tab (Advanced Level Graphs)

advanced tab screenshot

The Advanced Tab contain a medley of specialized options aimed at optimizing performance and allowing the advanced programmer greater flexibility. Note that this tab is only available when the Template Level on the global General Tab is set to Advanced.